Reply: New version of Plugin works with 3.6 and above

NOTE: You are posting the message as a 'Guest', you can not edit the message or delete it
Please Log in or Register to skip this step.
X

Topic History of: New version of Plugin works with 3.6 and above

Max. showing the last 6 posts - (Last post first)

  • admin
3 years 1 month ago
New version of Plugin works with 3.6 and above

Since the upgrade to 3.6 where Joomla changed how the JTable class is loaded, the Allow Duplicate email plugin no longer works.

I gave this a lot of thought and have now come up with a solution to those who really need this and are prepared to accept a compromise. The plugin has been completely rewritten and now has some additional options as well as working with all versions from 2.5 up.

For versions 3.6 and above the new plugin will actually replace the core class with the amended version. This is exactly the same class with the check for duplicate email commented out. When the core class changes i.e. if Joomla is upgraded, it will reinstate the amended class. When the plugin is uninstalled, it will reinstate the original core class. For versions below 3.6 it will work as before.

Here are the main differences:

  • The internal name of the plugin has changed it was allow_duplicate_email and is now called ade
  • If the old allow_duplicate_email plugin is installed it will be removed before ade is installed
  • New options allow logging of events and frequency of checking for changes
  • Core class will be replaced for 3.6 and above
The update site has not yet been updated to include these changes so if you wish to install the new version you will need to install it manually via the Joomla backend.

Download Link

Time to create page: 0.532 seconds
Powered by Kunena Forum