Joomla 3.6.4

  • Glenn Tooth
  • Topic Author
  • Visitor
  • Visitor
2 years 11 months ago #26 by Glenn Tooth
Joomla 3.6.4 was created by Glenn Tooth
Greetings

I am running Joomla 3.6.4 and have just installed the 2.02 version of your plugin. I have enabled it as well as cleared cache etc.

My Account Registration page is still giving me Duplicate Email Errors when I test :

"The email address you entered is already in use or invalid. Please enter another email address."

It would be great to get this working. Is there anything I can check?

Thanks in advance for your help.

G
More
2 years 11 months ago #27 by admin
Replied by admin on topic Joomla 3.6.4
Hi,

you can turn on logging in the plugin options - it should give you some information on what is happening. The logfile is in the plugins/system/ade folder.

Try setting the option "on every run" before you turn on logging, then try to add a user. Change it back to every 60 mins afterwards.

If the plugin runs successfully, it will make a copy of the original libraries/joomla/table/users.php file with a 3.6.4 suffix

Hope that helps!
  • Glenn Tooth
  • Topic Author
  • Visitor
  • Visitor
2 years 11 months ago #28 by Glenn Tooth
Replied by Glenn Tooth on topic Joomla 3.6.4
Thanks for your quick response. I have been investigating the issue and have a few more details.

I had been trying to do a Front-End User Registration and I always got the Duplicate Email Error here when trying to Register a New User with an already used email address,

However, when I add a user in the back-end I can setup a new user using an already existing email address.

I hadn't thought that they would be different but apparently they are.

Is this how the plugin works by design or do I still have an issue?

G
  • Glenn Tooth
  • Topic Author
  • Visitor
  • Visitor
2 years 11 months ago #29 by Glenn Tooth
Replied by Glenn Tooth on topic Joomla 3.6.4
I did what you said and also I played some more with the plug in and found an interesting fact..

I had been testing the plug by trying to use the "Create and Account" feature from the front-end. Using a duplicate email address here always gave be an error.

When I went to the back-end and tried to add a new user using an email address already in the system, I was able to do this.

I would have thought they would behave the same but I was wrong.

Is this the design behavior or do I still have a problem.

Thanks in advance.

G
More
2 years 11 months ago #30 by admin
Replied by admin on topic Joomla 3.6.4
It looks like there has been a change to the frontend form validation. It now uses a different methot to check for duplicate email. I have identified the changes that need to be made but it will take a little while to work out the best way of implementing this.

If you need this to work right now, you can manually update the following file:

components/com_users/models/forms/registration.xml

Change line 73 from unique="true" to unique="false"
Time to create page: 0.183 seconds
Powered by Kunena Forum